• Browser requirements

    Effective January 1, 2022 we will discontinue support for testers using Internet Explorer. After this date, we cannot guarantee that Maze will work with Internet Explorer, and will not address prob...